/

Minimal requirements

  • Android 2.3 and up
  • Recommended Android version is 2.3.3 and up
  • Google Play Services library has to be installed (it’s already installed in most android devices). A good way to check this is by seeing if you can run the Google maps app.
  • Some sort of communication with Flight Controller (Bluetooth, 3DR Radio, WIFI, USB)
  • Please be aware that on some very cheap Chinese devices this app may not work correctly

1 Comment

  1. What´s the reason for a Siswoo C55 Longbow Mobile with Lollipop 5.1 to be incompatible ?

Leave a Reply

© 2017 EZ-GUI

Theme by Anders NorenUp ↑